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i. This step is not required. It is simply a good idea to help prevent people 
from overriding your work or your work overriding theirs. 

ii. Go to http://www.ofpec.com/ 
iii. Create an account if you don’t have one already. 
iv. Go to http://www.ofpec.com/tags 

1. This area is here for addon makers to create and register their tag. 
2. Having a tag, and using it properly, helps to make sure that 

addons don’t override one another or elements of one another. 
b. Create a Tag. 

i. Type the tag you want into the “Tag” field and press the Check 
Availability button. 

ii. If your tag is available continue on. If not think of a new one and try 
again. 

iii. You if wish, fill out the rest of the form. 
iv. Hit Submit Tag. You now should have a tag. 
v. For now on I will refer to this as “Your Tag”.  

vi. I will be using abc as an example tag within this tutorial. 
2.) Install the ArmA 3 Tools 

a. Open Steam 
b. Hover over the “Library” button. 
c. Select “Tools” 
d. Locate “Arma 3 Tools” and install them. 
e. Once the install is finished, double click “Arma 3 Tools”. 
f. Select “Play Arma 3 Tools” and click “Play” 
g. Once you get to a page that says “Arma 3 Tools” and includes “Addon Builder” 

close the window. 
3.) Creating Your P Drive by M1lkm8n 

a. .Bat Setup 
i. The first thing to do before you start any kind of project in the RV engine 

is to properly set up your P: drive. This will mirror the way the engine 
sees all the files and help in keeping projects neat and tidy. There are 
many different way to set up a P: drive (using the bis program DevP for 
example) however I use my own little bat file so for this purpose we shall 
use that.  

ii. The .bat file is located in the “drive_setup” folder in the tutorial files. 
iii. A P: drive is essentially a just a virtual drive created when running the 

subst command in a dos shell. So navigate to where ever you wish to 
create your p: drive folder and create a new folder there. Since I followed 
the convention of Arma2, I created a folder in my documents folder 
called Arma3Work. 

iv. The next step is to set up the bat file called ArmaWorkSwitcher.bat to 
work with your newly created Arma3 work folder.  

v. Right click on the bat file and select edit.  

http://www.ofpec.com/tags
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vi. Starting from the 5th line down you will see “set patha2=”, then “set 
patha3=” and “set pathvbs=”.  

vii. Unless you work in any other these other games/programs the only one 
we need to edit is the set patha3=. You can see currently the path is set 
patha3=E:\Documents\arma3work.  

viii. Change the path after the equals sign to your newly created a3 work 
folder path. Then save and close the file. 

ix. Next step is to run the bat file and select the appropriate selection which 
in the case of Arma 3 would be the number three.  

x. Press Enter and you will see "Created A3 P:\ Drive". 
xi. Since I don't like things starting up without my consent the 

armaworkswitcher.bat will need to be run once every time you start your 
computer. 

xii. I leave the file on my desktop for quick access. 
xiii. Now you're ready to populate that drive with all the necessary files! 

 
b. ArmA3P 

i. For this set we will use arma3p.bat created by Mikero.  
ii. The first step is to download all the required files from his dev heaven 

page which is located here:http://dev.withsix.com/projects/mikero-
pbodll/files?sort=created_on%3Adesc%2Cfilename 

iii. Arrange the files by Date and download and install the following 
programs: 

1. ExtractPBO 
2. DeRap 
3. Depbo dll 
4. ArmA3P 

iv. Once all the required files have been downloaded and installed run 
ArmA3P. 

v. This will take some time but will copy all A3 content onto your P drive 
and help setup Buldozer. (Note: Make sure you have plenty of file space 
on whatever folder you created your ArmA3 P drive on.) 

vi. Once that is complete you are now ready to move on to the next step. 
 

4.) Setting Up Your Project 
a. Go to your P drive (P:\) 
b. Create a folder called “scripts” 
c. Create a folder and name it the same as “Your Tag”. 

i. This is your workspace. For now on any terrain or addon you make should 
go in this folder. 

ii. Having a workspace folder helps keep your P Drive organized and clutter 
free. 

http://dev.withsix.com/projects/mikero-pbodll/files?sort=created_on%3Adesc%2Cfilename
http://dev.withsix.com/projects/mikero-pbodll/files?sort=created_on%3Adesc%2Cfilename
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iii. If you intend on working on things other than terrains, it could be 
beneficial having a folder called “Terrain” or “Maps” but leave that out 
for this project or things will become more confusing. 

d. Within your workspace create another folder called 
“YourTag_YourProjectName”  

i. This is your project folder. 
ii. Determine what you want “Your Project Name” to be. 

iii. In this tutorial I will be using SampleMap. 
iv. My folder would then be called “abc_SampleMap” and would be found in 

the P:\abc\ directory. 
e. Within your project folder create a data folder as well as a source folder 
f. Move the files that came with this tutorial to their appropriate location. 

i. Move the files from the “textures” folder into 
“P:\yourtag\yourproject\data”. 

ii. Move the files from the “source” folder into 
“P:\yourtag\yourproject\source”. 

iii. Move the files from the “configs” folder into “P:\yourtag\yourproject”. 
iv. Move the file “editor.sqs” from the “scripts” folder into “P:\scripts”. 
v. Leave everything else where it is for now. 

5.) Change Textures, RVMAT Paths, and Layers.cfg 
a. Textures 

i. In your data folder, there should be 15 files; 10 textures, and 5 rvmats 
ii. Change the yourtag_yourproject part of each name to reflect your 

current project (ex. abc_sampleMap_dirt_co.paa) 
b. RVMAT Paths 

i. In the data folder, you should have five files called; 
1. yourtag_yourproject_dirt.rvmat 
2. yourtag_yourproject_dry_grass.rvmat 
3. yourtag_yourproject_forest_pine.rvmat 
4. yourtag_yourproject_grass_green.rvmat 
5. yourtag_yourproject_soil.rvmat 

ii. You should’ve already renamed all of these to reflect your project.  
iii. Open the file that ends in “_dirt.rvmat”. 
iv. There are two lines that say “Source Name”. 
v. One of them points to your “*_dirt_nopx.paa” texture and the other to 

your “*_dirt_co.paa” texture. 
vi. Change the file path and the file name in both fields to point to the 

correct file (ex. 
“abc\abc_sampleMap\data\abc_sampleMap_dirt_nopx.paa” & 
“abc\abc_sampleMap\data\abc_sampleMap_dirt_co.paa”). 

vii. File > Save or CTRL + S to save the file. 
viii. Close the file and use the same process to adjust the other four.  

c. Layers.cfg 
i. In your “source” folder you should have a file called layers.cfg. 
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ii. Open it. 
iii. Change each instance of yourtag to your tag (ex. abc) and each instance 

of yourproject to your project (ex. sampleMap). Note: The Edit>Replace 
function in your test program is useful here. 

iv. Save the file. 
 

6.) Project Creation 
a. Open Terrain Builder 
b. Adding a Mapframe 

i. Mapframe > Add Mapframe 
ii. A window titled “UTM Selection” will open. 

iii. Make sure it says Zone: 31 (0°E – 6°E) Subzone: N 
iv. Press OK 

c. Editing Mapframe Location Properties 
i. You will now be in a window called “Mapframe Properties” and will also 

be on the “Location” tab within this window. 
ii. Change Name to yourTag_yourProject 

iii. Direct the Output root folder field to P:\yourtag\yourproject using the 
“…” button. 

iv. Press “Create subfolders” 
1. This will create the folders “landbuilder”, “shapefiles”, and 

“TerrainBuilder” within source folder. If you were to skip creating 
the data and source folder before this step then it would also 
make the data and source folder. 

v. Set the Easting to 200000. 
vi. Set the Northing to 0. 

d. Editing Mapframe Samplers Properties 
i. Switch to the “Samplers” tab. 

ii. Within the “Terrain Sampler” box select the following: 
1. Grid size: 512 x 512 
2. Cell size (m): 4.0 
3. Terrain size (m): 2048 

iii. Within the “Satellite/Surface (mask) source images” box select the 
following: 

1. Size (px): 2048 x 2048 
2. Resolution (m/px): 1.0 

iv. Within the “Satellite/Surface (mask) tiles” box select the following: 
1. Size (px): 512 x 512 
2. Desired overlap (px): 16 

v. Within the “Texture layer” box select the following: 
1. Size (m): 32 x 32 

e. Editing Mapframe Processing Properties 
i. Switch to the “Processing” tab. 
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ii. Direct the “Layers config file (layers.cfg)” field to 
P:\yourtag\yourproject\source\layers.cfg by using the “…” button. 

iii. Press Rebuild terrain 
iv. A new window pops up. 
v. Press Yes 

vi. The “Ok’ option should no longer be greyed out. 
vii. Press Ok 

f. Make sure the “View mapframes” button   is selected. Note: There are two 
buttons that look like this and this one is the one on the right. 

 
7.) Save Your Project 

a. Go to File > Save 
b. Select P:\yourtag\yourproject\source\TerrainBuilder\ 
c. Save your field as your project name. 
d. Make sure you save your project frequently. 

8.) Bare Earth Elements Import 
a. Importing the Heightmap 

i. Make sure the “View terrain heightmap” button is selected. 
ii. Go to File > Import > Terrains 

iii. Select heightmap.asc from P:\yourtag\yourproject\source  
b. Importing the Surface Mask 

i. Make sure the “View surface mask image” button  is selected. 
ii. Go to File > Import > Surface mask images 

iii. Select mask_lco from P:\yourtag\yourproject\source 
iv. A window called “Project of mask_lco.bmp” will pop up. 
v. Make sure the settings are the following: 

1. Easting: 200000.000 
2. Northing: 0.000 
3. Resolution: 

a. X (m/px): 1.000000 
b. Y (m/px): 1.000000 

vi. Press OK 
c. Importing the Satellite Imagery 

i. Make sure the “View satellite image” button  is selected. 
ii. Go to File > Import > Satellite Images 

iii. Select sat_lco from P:\yourtag\yourproject\source (Note: You may 
choose to select sat_lco_alternate instead if you wish. Sat_lco is the 
original real world imagery and sat_lco_alternate is one that was created 
in photoshop) 

iv. A window called “Project of sat_lco.bmp” will pop up. 
v. Make sure the settings are the following: 

1. Easting: 200000.000 
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2. Northing: 0.000 
3. Resolution: 

a. X (m/px): 1.000000 
b. Y (m/px): 1.000000 

vi. Press OK 
d. Generating the Layers 

i. Open up your mapframe by going to the Mapframes View and then 
double-clicking or right-clicking and selecting properties on your 
Mapframe. Note: If you don’t see the Mapframes View go to Windows > 
Mapframes View 

ii. Go to the “Processing” tab. 
iii. Press the “Rebuild terrain” button. 
iv. Press Yes. 
v. Make sure the “Layers config file (layers.cfg)” field is directed to your 

“P:\yourtag\yourproject\source\layers.cfg” 
vi. Check the “Export satellite texture” box. 

vii. Check the “Export surface mask” box. 
viii. Bubble in the “4 materials per cell” bubble. 

ix. Check the “Save RVMAT files in ASCII format” box. 
x. Check the “(DEBUG)Store suffix(DEBUG)” box. 

xi. Press the “Generate layers” button. 
xii. A new window with a progress bar will pop up. 

xiii. Be patient. 
xiv. When it is done press “Ok” 

e. This is a good place to save! 
f. Connecting to Buldozer 

i. Press the “Connect to Buldozer” button . 
ii. A new application window should pop up. 

iii. Sometimes this will crash and you may need to try to connect a few 
times. 

iv. If it goes well, a smaller window will pop up and start going through a list 
of textures. 

v. When this is done you should see your heightmap covered with your 
satellite imagery and surface mask. You may need to click in the viewer 
window. 

vi. Buldozer Controls 
1. Movement 

a. “Mouse” – Move Around 
b. “Left Arrow” – Left 
c. “Right Arrow” – Right 
d. “Up Arrow” – Forward 
e. “Down Arrow” – Back 
f. “Shift + Mouse” – Move Fast 
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g. “Numpad 8” – Orbit Camera Up 
h. “Numpad 2” – Orbit Camera Down 
i. “Numpad 4” – Orbit Camera Right 
j. “Numpad 6” – Orbit Camera Left 
k. “Numpad +” – Zoom In 
l. “Numpad –“ – Zoom Out 
m. “Hold Numpad 5” – Free Look 
n. “Numpad 0” – Reset Camera 
o. “Q” OR “Page Up” – Raise Altitude 
p. “Z” OR “Page Down” – Lower Altitude 

2. Application 
a. “F1” – Menu 
b. “S” – Select Mode 
c. “F5” – Activate Snap Points (Magnetize Points) 
d. “C” – Copies objects in Buldozer  (Duplicate Selection) 
e. “D” – Removes objects in Buldozer  (Remove Selection) 
f. “Hold T” – Show Texture Info 
g. “Alt + Tab” – Move back to Terrain Builder 
h. “Alt + F4” – Quit 

3. Object Manipulation (Normal Mode) 
a. “Left Click” (On Object) – Select Object 
b. “Shift + “ – Will speed up some operations when used in 

conjunction 
c. “Spacebar” – Select (while cursor over object) 
d. “Left Click + Hold” – Move Object 
e. “Left Click + Page Up” – Raise Object Elevation 
f. “Left Click + Page Down” – Lower Object Elevation 
g. “W + Right Click + Move Mouse” – Elevate 
h. “Right Click + Hold + Move Mouse” – Rotate Object 

Around Cursor 
i. “Right Click + Hold + Shift + Move Mouse” – Rotate 

Object(s) Around Object(s) 
j. “Left Ctrl+Z” – Undo (Unknown Function) 
k. “Left Ctrl+R” – Redo (Unknown Function) 
l. “V” – Create Object (last object selected) 
m. “E + Right Click + Move Mouse” – Scale Object 
n. “Z + Right Click + Move Mouse” – Rotate Y (will also lower 

object) 
o. “X + Right Click + Move Mouse” – Rotate X 

4. Standard Terrain Manipulation 
a. “H” – Show Terrain Node 
b. “U” – Raise Terrain 10cm 
c. “I” – Raise Terrain 50cm 
d. “O” – Raise Terrain 1m 
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e. “P” – Raise Terrain 5m 
f. “J” – Lower Terrain 10cm 
g. “K” – Lower Terrain 50cm 
h. “L” – Lower Terrain 1m 
i. “;” – Lower Terrain 5m 

5. Brush Mode 
a. “Left Click” – Raise Terrain 
b. “Right Click” – Lower Terrain 
c. “B + Mousewheel” – Change Brush Ratio (Green  Inner 

Vertices) 
d. “N + Mousewheel” – Change Radius of Outer Vertices 

(Red) 
e. “M + Mousewheel” – Change Brush Density 
f. “Hold Left-Shift” – Flatten Tool 

i. Left-Shift + M + Mousewheel – Change Flatten 
Factor 

g. “Hold R” – Smooth Tool 
i. R + M + Mousewheel – Change Smooth Factor 

6. Unknown Functions 
a. “Insert” – Switch Camera (Unknown Function) 
b.  “F6” – Magnetize Planes (Unknown Function) 
c. “F7” – Magnetize Fixed Y (Unknown Function) 
d.  “R” – Randomize 

g. You can use alt + tab to get back to the Terrain Builder window or if you want to 
exit you can use alt + f4. 

h. Use alt+f4 to exit. 
 

9.) A Quick Note About Layers 
a. Layers are a fairly common design element in editing programs. 
b. They allow you to place items in a layer to perform multiple functions. 
c. Generally speaking, you can only perform actions on objects or items in the layer 

you have specified. 
d.  “Rasters” tab of the “Layers manager”, you are able to: 

i. “Show/Hide a layer” – Adds/Removes the layer from view. 
ii. “Lock a layer” – Makes the layer “un-editable” as long as it is locked. 

Note: Be careful with this one too because there are some situations 
where locking one does not prevent you from editing it. 

iii. “Fit to View” – Centers the main window on the full selected layer. 
iv. “Show all terrain data” – Shows all terrain layers. 
v. “Hide all terrain data” – Hides all terrain layers. 

e. “Objects” tab: 
i.  “Add new layer” – Creates a new layer 

ii. “Delete a layer” – Delete a layer (be careful with this one!) 
iii. “Hide a layer” – Adds/Removes the layer from view.  
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iv. “Lock a layer” – Makes the layer “un-editable” as long as it is locked. 
Note: Be careful with this one too because there are some situations 
where locking one does not prevent you from editing it. 

v. “Make layer transparent” – Seemingly no function 
vi. “Allow interlayer selection” – Allows you to select objects from multiple 

layers 
vii. “Hide all layers” – Hides all the layers 

viii. “Show all layers” – Makes all layers visible 
ix. “Slide Transparency” – Use the slider at the bottom to adjust layer 

transparency. 
f. “Shapes” tab: 

i. “Add new layer” – Creates a new layer 
ii. “Delete a layer” – Delete a layer (be careful with this one!) 

iii. “Hide a layer” – Adds/Removes the layer from view.  
iv. “Lock a layer” – Makes the layer “un-editable” as long as it is locked. 

Note: Be careful with this one too because there are some situations 
where locking one does not prevent you from editing it. 

 
10.)  Shapefiles & Roads 

a. Importing Roads 

i. Make sure the “View shapes” button is selected. Note: There are two 
buttons that look like this and this one is the one on the left. 

ii. File > Import > Shapes 
iii. Locate the shapefiles folder that came with this tutorial and choose 

“roads_dirt.shp” for import. 
iv. A new window called “Import wkt file” will open.  
v. Press Ok. 

vi. You should now see purple lines covering dirt roads on your terrain. 
vii. There will also be a new layer called “Dirt Roads” in the “Shapes” tab of 

your “Layers manager” 
b. Creating Roads 

i. The main highway is missing from the map. 
ii. If you’re not there already, go to the “Shapes” tab in the “Layers 

Manager”. 
iii. You should see a layer called “Dirt Roads” and another called “default 

area”. 

iv. Press the “Add New Layer” button  in the “Layers Manager”. 
v. A new window called “Layer name” will open and ask for a name. Call it 

“Main Highway”. 
vi. Make sure you have the “Main Highway” layer selected (it will be white) 

and go to the “Add Polyline” button  on the toolbar. 
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vii. Put your cursor over the southern end of the main highway and zoom in 
using the mouse wheel. 

viii. You can also move your view by clicking and holding the right-mouse 
button and moving the mouse, 

ix. Click the left-mouse button on the end of the highway. 
x. A dot will appear with a line going to your cursor.  

xi. Keep placing dots along the highway until you get to end of the highway 
at the top of the map.  

1. Make sure to keep the line along the center of the highway to the 
best of your ability. 

2. You can use the right-mouse button and drag trick to move along 
the road. 

3. When the road goes into the trees use your best judgment to 
follow the road. 

4. When you reach the end of the road double-click to end the road 
placement. 

xii. Look back over your road. 
xiii. Save your project. 

c. Modifying Roads 

i. Select the “Edit Selection” button on the top toolbar. Note: The “Edit 
Selection” button and the “Layer Selection” button look similar. The “Edit 
Selection” button is on the left. 

ii. Click the “Main Highway” line to see your points. 
iii. If you see a point you would like to move, click on it once so it turns what 

I think is an olive color and then click and hold to move it around. 
iv. If you wish to remove a dot, right-click and go to “Remove selected 

vertices” 
d. Adding Road Properties 

1. When you are satisfied with the road, right-click on it and go to 
“Database properties”. 

2. At the bottom it says “New…”. Press it. 
3. A new window called “New field” will pop up and ask for two 

inputs. 
4. Name the new field “ID” and give it a type of “float”. 
5. Press Ok. 
6. You should now have a new field called “ID” with a type of “float” 

underneath it. 
7. In the cell where “polyline” meets the “ID” field type 1. 
8. Create another field called “Order” with a type of “float” and 

enter 0 into the field. 
9. Press “Ok” 

e. Exporting 
i. Go to File > Export > Shapefile. 
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ii. A new window called “Export shapes to shp file” will appear. 
iii. Bubble in the “Document” bubble. 
iv. Click the “…” button and locate your project’s data folder. 
v. Make a new folder called “roads”. 

vi. Open the new “roads” folder and give your file the name of “roads”. 
Note: Just call it roads. If you name it anything else the Buldozer preview 
won’t work. 

vii. Press Open. 
viii. Press Ok. 

ix. A new window will pop up called “TerrainBuilder Information” and say 
“Export SHP – DONE!” 

x. Press Ok. 
f. Viewing 

i. Setting Up Editor.sqs 
1. Locate your P:\scripts folder and use notepad to edit “editor.sqs” 
2. Change the file path on line 3 to point to your newly created 

“roads” folder. (ex. “P:\abc\abc_SampleMap\data\roads\”) 
a. Note: This path must be changed whenever you work on a 

new terrain. 
3. Save the file and close. 

ii. Roads Library 
1. Locate the “RoadsLib.cfg” file in the “shapes” folder of the sample 

data. 
2. Copy this to the “roads” folder that you recently created. 

iii. Go back to Terrain Builder and press the “Connect to Buldozer” button

. 
iv. You may get an error message. If so, make note of what it says. 
v. You should be able to navigate to an area and view your roads now. 

There should be one that is a highway and several dirt roads. If you can’t 
see the roads, take a look back at the directions and see if you might have 
missed one. Note: If you change your roads they will need to be re-
exported into the roads folder over the original file. Or you could create a 
new file and change the path in “editor.sqs” 

vi. Use alt+f4 to close Buldozer when you are ready. 
vii. Save. 

 
11.)  Objects 

a. Object Libraries 
i. Importing Object Libraries 

1. Go to the “Library manager” panel and click the “Load template 

library” button .  
2. Navigate to the sample files “objects” folder and then open the 

“libraries” folder. 
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3. Select all the .tml files in this directory and press “Open”. 
4. A window called “Load library” will pop up and ask if you want to 

“copy this library to the current project?” 
5. Press “Yes”. 
6. This will happen for each library and you will want to press “Yes” 

for all of them. 
7. You should now have four libraries on the left called “Houses”, 

“Other Objects”, “Small Objects”, and “Tree”. 
ii. Creating an Object Library from a Directory 

1. Press the “Create new template library” button . 
2. A new window will pop up called “Create new library”. 
3. Check the “Create new library from directory” box. 
4. Set the source directory to “P:\a3\structures_f\walls” by using the 

“…” button and navigating to the directory. 
5. Press the “…” button next to the “Fill Color” color box and set the 

color to bright red (first column, second row). 
6. Use the same process to set the “Outline color” box to black. 
7. The “Name” field should say “walls”. 
8. Change the lowercase “w” in walls to a capital “W” because I am 

picky and want it to match with the rest of the template libraries. 
9. Press Ok. 
10. A new template library shows up called “Walls”. 

iii. Creating an Object Library using Individual Models 

1. Press the “Create new template library” button . 
2. A new window will pop up called “Create new library”. 
3. Type “Bush” into the “Name” field. 
4. Set the “Fill color” to bright green (three columns over and three 

rows down). 
5. Set the “Outline color” to black. 
6. Bubble in the “Ellipse” bubble. 
7. Press Ok. 
8. You should now have a new empty library called “Bush”. The (0) 

next to it means that it has no objects assigned to it. In other 
words empty. 

9. Select the “Bush” library and press the “Add new template” 

button . You may also right click on the “Bush” library and go to 
“Add new template”. 

10. A new window called “Create new template” will open. 
11. Click the “…” button after the “Object file” field. 
12. Navigate to “P:\a3\plants_f\Bush\” and select the 

“b_FicusC1s_F.p3d” file. 
13. Press “Open”. 
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14. The “Name” field should automatically be filled in with 
“b_FicusC1s_F”. 

15. Leave everything else as is. 
16. Press “Ok”. 
17. Do the same process for the following models all of which are 

located in the “P:\a3\plants_f\Bush\” folder: 
a. b_ficusC2d_F.p3d 
b. b_ficusC2s_F.p3d 
c. b_NeriumO2d_F.p3d 
d. b_NeriumO2s_white_F.p3d 

18. You should now have a “Bush” library with five different models in 
it. 

iv. Changing Object Properties 
1. Click the “+” button next to the “Bush” template library. 
2. A list of bushes should come up. 
3. Left-click on one of the bush models and the properties for that 

model will show up in the “Template properties” panel. 
4. Edit the following attributes for the selected bush to the following 

(Tip: Click in the top box and use tab to navigate down the list 
typing in numbers as you go): 

a. Pitch + (deg): 2 
b. Pitch – (deg): 2 
c. Roll + (deg): 2 
d. Roll – (deg): 2 
e. Scale + (%): 5 
f. Scale – (%): 5 
g. Yaw + (deg): 180 
h. Yaw – (deg): 180 (Note: After typing in this value, click on 

the main screen in the middle. If you click on the next bush 
before doing this the last value will stay as 0) 

5. Set the remaining bushes to the same settings. 
6. Save 

b. Importing Objects 

i. Make sure the “View scene objects” button  on the top toolbar is 
selected. 

ii. Make sure the “View textured objects” button  on the top toolbar is 
NOT selected. 

iii. Go to the “Objects” tab in the “Layers manager”. 

iv. Click the “Add New layer” button  and name it “Farms”.  
v. Go to File > Import > Objects 

vi. Navigate to the source files from this tutorial and locate the “objects” 
folder. 
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vii. Select the file “farms.txt” for import and hit “Open” 
viii. Do this same process for the “forests”, “heather”, “plants”, and “small 

objects” files. 
1. New Layer and rename 
2. File > Import 
3. Select the file 
4. Repeat 

ix. Once your done you should have almost the entire map populating by a 
mixture of farms, plants, and small objects. Note: I want to make it clear 
that these are objects I placed either manually or by using the Fill tool 
which you will learn about shortly. Data does not come in pre-made 
packages like this outside of tutorials. Thus, terrain making can be time 
consuming. 

x. There will however be an area up in the north-west that is lacking some 
of this and that is what we will focus on next. 

c. Object Placement 
i. Individual Objects 

1. Create a new object layer called “NW Farm” 
2. There is a farm that is lacking buildings in the north-west corner of 

the map 
3. Navigate to there and zoom in. 
4. Select your “Houses” library in the “Library manager” and expand 

it by hitting the + to the left if it isn’t open already. 
5. Locate the name/model “i_House_Small_02_V3_F” on the list of 

models in the “Library manager” and select it. 

6. Now click the “Add object” button on the toolbar. 
7. Left-Click on the farm where you would like to place this house 

and the model will appear. 
8. Feel free to select other objects and add them as well. 
9. We will get to rotating and moving them around after the next 

section. 
ii. Fill Objects 

1. Next we want to create the forests that are to the east of this 
farm. 

2. Draw Shapes 
a. If you’re using the sat_lco you should be able to see the 

forests to the east clearly. 
b. If you’re using the sat_lco_alternate, you should see a 

browner area on the satellite imagery just to the east. 
These are the forests. 

c. Additionally, you could always “Hide” the satellite imagery 
so that you can see the mask which will give you a clear 
picture of where the forest is as well. 
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d. We are going to make two types of forest; a deciduous 
forest (leafy) and a coniferous forest (pine). 

e. Move over to the “Shapes” tab in the “Layers manager” 
and make a new layer one called “Forests”. 

f. With this layer selected, select the “Add polygon” tool 

 from the toolbar. 
g. This works similar to the “Add polyine” tool that we used 

in the “Creating Roads” section only it makes shapes 
instead of lines. 

h. Begin to make a shape around the western most forest by 
left-clicking to place the first point and then left-clicking to 
create any additional points afterward. 

i. When you get to your last point double-left-click to “Finish 
and Close the Shape” 

j. Use this same process to create two more forests; one 
immediately to the east and another to the south of that 
one. 

k. If you would like, you can select the “Edit selection” tool 
from the toolbar, click the shape, and change the color by 
going to the “Properties” panel and clicking the color next 
to where it says “Fill color:”. You can change the color of 
multiple shapes by selecting multiple ones using ctrl + left-
click and doing the same process. 

3. Filling Forests 
a. Go back to the “Objects” tab in the “Layers manager” and 

create a new layer called “New Forests”. 
b. Select the forest on the left and right-click on it. 
c. Select “Fill(add new objects)” 
d. We want to make forests that consist of trees and bushes, 

so there is no reason to have any of the other libraries 
open. Uncheck all libraries except for “Tree” and “Bush”. 
You will see objects vanish from the “Available Templates” 
window on the right. 

e. Select “b_FicusC1s_F” from the “Available templates” 
window. 

f. Now hold ctrl and select “b_FicusC2s_F”, 
“t_FraxinusAV2s_F”, and “t_QuercusIR2s_F”. 

g. Type “Leafy” into the “Preset name:” field. Note: You must 
fill this out in order to be able to use fill. At the present 
moment, it really doesn’t matter what you type here 
because it doesn’t allow you to load presets. However, it 
will remember if you used  a name before and not allow 
you to use it again. 
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h. Change “Objects density (per hectare):” to 60. 
i. Leave the rest of the settings. 
j. Press “Ok”. 
k. There should now be plants filling in the polygon. 

4. Clearing Fills 
a. Let’s say that the density of 60 is too low and we want to 

redo that to make the forest denser. 
b. Select the shape and right-click again. 
c. This time select “Refill (clear and fill)”. 
d. Select any object from “Available templates”. 
e. Set your preset name to whatever you would like as it 

won’t be used ever again. 
f. Press “Ok”. 
g. Your previous forest should now be cleared. 

5. Fill Again 
a. Follow the steps from the “Filling Forests” stage until you 

get to object density. 
b. Change “Object density (per hectare):” to 130. 
c. Leave the rest of the settings. 
d. Press “Ok” 
e. You should now have a denser forest. 

6. A New Forest 
a. We’re going to do two more forests now. 
b. Select the forest to the east of the one you just filled. 
c. Follow the same plan as the “Filling Forests” stage but 

instead of selecting the same four plants select the 
following instead; “b_FicusC2s_F”, “t_PinusS2s_F”, and 
“t_PinusS2s_b_F” 

d. Set the density to 130. 
e. Leave the rest of the settings. 
f. Press “Ok” 
g. You should now have a nice pine forest. 
h. Do the same, using the same settings, on the forest to the 

south. 
i. We are now done with forests 

d. Modifying Objects 
i. Using the “Properties” Panel 

1. Go back to your “NW Farm” layer in the “Objects” tab of the 
“Layers manager”. 

2. Select the house that you placed. 
3. Locate your “Properties” panel. 
4. Find the “Rotation” subcategory and the “Yaw (Y): deg” field. 
5. Type “90” into that field and hit enter. 
6. The building will rotate to the 90 degree position. 
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7. Now try “35”. 
8. The building will rotate to the 35 degree position. 
9. Notice that these are absolute rotations and not relative to the 

present rotation, meaning; if you rotate it by putting “90” into 
that box twice, it will stay at the 90 degree position and not go to 
the 180 degree position unless you check the “Relative Mode” 
box at the top. 

10. In most cases, at least when it comes to houses, you don’t need to 
worry about “Pitch(X)” or “Roll(Z)” as they are used to tilt objects. 
This is useful in certain situations but the majority of objects you 
place won’t need adjustments for their Pitch or Roll. 

11. Scale is another option but should generally not be used with 
houses. This controls how large the model is and will look weird If 
you use a number smaller or larger than 1. It is useful on more 
natural objects or certain manmade ones. 

ii. Using the Mouse & Keyboard to Modify Objects 
1. The quickest way to modify an object is in the Terrain Builder 

“main window” using the mouse and keyboard. However, there 
are limited functions. 

2. You can select two or more objects by first left clicking one and 
then holding CTRL and selecting another. 

3. You can move objects by left clicking on them and dragging them 
4. You can rotate objects using either Shift + CTRL + RMB + Mouse 

Movement or Shift + ALT + RMB + Mouse Movement. Note: I have 
had experiences where doing this as soon as you open Terrain 
Builder will crash Terrain Builder. Be careful. 

5. Selecting an object and pressing Delete will delete it. 
iii. Using Buldozer to Modify Objects 

1. See the “Buldozer Controls” section under “Connect to Buldozer” 
 

e. Exporting Objects 
i. You can also Export objects if you wish. This is useful if you want to move 

them into a different project. This will not help you now but I thought I 
would point it out. 

ii. Go to File > Export > Objects 
iii. There are three main selection types for exporting objects; 

1. Document – All objects on the map 
2. Selection – Objects currently selected 
3. Active Layer – The layer that is presently selected 

iv. If you have more than one type of object selected you can choose which 
type to export by selecting them in the “Available templates” window. 

v. Leave the “Terrain Builder format” option selected but be aware that you 
can export in other formats. 

vi. Choose your destination. 
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vii. When picking your File name make sure to add a .txt onto the end of it or 
it will not be selectable in the “Import Objects” window. 

f. Moving Objects Between  Layers by Bushlurker 
i. Sometimes you might accidentally place an object in the wrong layer or 

want to move one. 
ii. Determine if you want to move the objects to a new layer or to an 

existing one. If you want them to go to a different layer create one now. 
iii. Select the objects that you want to move to another layer. 
iv. In the “Properties” panel, change the “Layer:” field to the layer you want 

to send the objects to by using the dropdown menu. 
 

12.)  Exporting WRP 
a. In order to get your terrain in-game you need to export the WRP which is the 

world file containing all the data from Terrain Builder. 
b. Go to File > Export > WRP 
c. Save it to your root project folder P:\yourTag\yourProjectFolder  
d. Call the file yourtag_yourproject (ex. abc_sampleMap.wrp) 
e. And we are now done in Terrain Builder! 

13.)  Altering Files & Paths 
a. Change the pictureMap name 

i. In your data\imagery folder there is a file called 
yourtag_yourproject_pictureMap 

ii. Rename the file by replacing yourtag with your tag and yourproject with 
your project. (ex. abc_sampleMap_pictureMap.paa) 

b. Change cfgClutter 
i. In your project’s root folder there should be a .hpp folder called 

cfgClutter. 
ii. Open it. 

iii. Replace every instance of yourtag with your tag and every instance of 
yourproject with your project. (ex. 
abc_sampleMap_BigFallenBranches_pine) Note: The Edit > Replace is 
your friend on this. 

iv. Save the file when you’re done. 
c. Change cfgSurfaces 

i. In your project’s root folder there should be a .hpp folder called 
cfgSurfaces. 

ii. Open it.  
iii. Replace every instance of yourtag with your tag and every instance of 

yourproject with your project. (ex. abc_sampleMap_dirt_Surface) 
iv. Save the file when you’re done 

d. Change config.cpp 
i. In your project’s root folder there is a file called config.cpp. 

ii. Open it. 
iii. Guess what you get to do! 
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iv. Replace every instance of yourtag with your tag and every instance of 
yourproject with your project. (ex. class abc_sampleMap) Note: Find and 
replace isn’t as useful on this one so make sure you catch all the entries. 

v. Save it when you’re done. 
 

14.)  Pack your Terrain, put it in a mod folder, and you’re done! 
a. I recommend using Mikero’s PBO Project to pack your terrain. It is a great tool 

and all I have used for years. 
b. Put the resulting pbo (found in P:\Dist) in your mod folder. Note: You will notice 

sand around your terrain. That is supposed to be there to help you see the area 
you just did. 
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